Noël Café : Blog

Noëlの公開備忘録とひとりごと。コメント・トラックバックご自由に

MT3.36じゃPost to VoXプラグイン使えないよ・・・

VoXのユーザーもなんとなく取得したので、
プラグインを使用してクロスポストしようと思いました。
しか~し。
まったく出来ず。
一応参考にしたことを書いておきます。


MTからVoXへのクロスポストは
PostVoxというプラグインを使用します。
現段階で出ているのはMT4のものです。
探していたら、MT3以前用を発見。
野良plu: PostVox at Tech Talk Blog (Six Apart内)
ここの、実食ってところにあるmt-postvox-0.04.zipです。
下の方にあるコメントを見ていたら、
MT3.35以降で動かなくなるとのこと。
直したものが、
http://code.sixapart.com/svn/mtplugins/trunk/PostVox/
にあると書いてあるのだが・・・
動かしてみると、「MT4以上でないと動作しない」と表示され使用できない。
そんなわけで、PostVox Ver 0.4 を試してみることに。
当然エラーが出ます。

Couldn’t retrieve ‘apiLink’ from HASH(XXXXXXX)

PostVox作者のBlogを見たら、
PostVox復活 at Living on the Edge
というものが。
RSDからATOMに変更したら動いたらしいので
一か八かでその部分だけ変更し、トライ。
当然無理でした。
MTからvoxへのクロスポスト2 at A::logさんを
拝見させていただいたら、
解決策があるのでは??
と思いリンク先をクリック。
しかし、リンク先は存在しなかった・・・。
でも、そこは意地と根性で書いてあるところを発見。
PostVoxに成功! at kwlog
私の場合は当てはまらないような気がするも、一応トライ。

my $apilink = $config->{vox_apilink};

my $apilink = undef;

へ変更。
どう検索しても(日本語の範疇では)出てこないので、
PostVoxの使用はMT3.36では今回はあきらめました・・・。


取り急ぎ?(別にやらなくていいんだけど)MTのATOMフィードを
読み込ませることが出来るらしいので、そいつをやってみた。
ちゃんと取り込めたけど、改行なくなっちゃったわ・・・。
他ブログから記事を読み込む from Voxヘルプ


クロスポストプラグイン from WolaWola
にて、CrosPosterというのも発見したけど、
これも、MT4以上からみたい。
あぁぁ~(諦)。

Leave a Reply

*


CAPTCHA



Trackback URL